[Digikam-users] I broked it :-( - dependency problems

Gilles Caulier caulier.gilles at gmail.com
Fri Oct 14 08:36:03 BST 2011

These XML file come from OpenCV. We are copied some of them because
openCV do not include it in official release (especially in Windows
install), or are packaged in a separated package (like there is a bin
package and a data package)

Gilles Caulier

2011/10/14 e-mail robert.m.davies <robert.m.davies at blueyonder.co.uk>:
> I am unable to install digikam since I tried to compile from source.
> I will list the steps I took below.
> If anyone can help me to get digikam back up and running, I'd be very
> appreciative.
> I had digikam2 installed and working from the PPA under 11.04
> I reported a bug, and was offered help if I could run from the latest git
> version.
> So I uninstalled the digikam2 package and I cloned the digikam2 source onto
> my home partition using git.
> I tried to compile, but I didn't have all the correct dependencies.
> I started installing dependencies 1 by 1 using the method on this page:
> http://ubuntuforums.org/showthread.php?t=718183
> After about 6 dependencies, I decided there had to be a better way.
> I found this page: http://www.digikam.org/drupal/download/dependencies
> I tried running 'sudo apt-get build-dep digikam2', but it failed with
> errors. I guess (and only guess) that it was because of the packages I had
> installed manually.
> I don't know how to resolve dependency conflicts. I don't know how to force
> a package to install.
> I gave up trying to install from source and decided to install from the
> repository again, but now this fails with dependency errors too.
> I left it for a while and tried to muddle through using gwenview.
> Today I upgraded to 11.10.
> Digikam still won't install.
> When I try to install 'digikam' from the repository, I get the following
> error:
> Package:
> /var/cache/apt/archives/libkface-data_1.0~digikam2.1.1-0ubuntu1_all.deb
> Error: trying to overwrite
> '/usr/share/kde4/apps/libkface/haarcascades/haarcascade_mcs_righteye.xml',
> which is also in package libkface-1 2.0.0-natty~ppa7kde47
> Package:
> /var/cache/apt/archives/libkface1_1.0~digikam2.1.1-0ubuntu1_amd64.deb
> Error: trying to overwrite '/usr/lib/libkface.so.1.0.0', which is also in
> package libkface-1 2.0.0-natty~ppa7kde47
> From the look of it, it might be worth mentioning that I was subscribed to
> the kubuntu backports ppa, and updated to latest kde before the distro
> upgrade to 11.10
> Based on this, is anyone able to help me? I miss digikam!
> Rob
> _______________________________________________
> Digikam-users mailing list
> Digikam-users at kde.org
> https://mail.kde.org/mailman/listinfo/digikam-users

More information about the Digikam-users mailing list