[Digikam-users] Any interests in Digikam 2.0 packages and digikam PPA?

Larry CK blackravener at gmail.com
Thu Oct 6 19:18:42 UTC 2011


Eric,

not that it is going to solve your problem, but I'm getting exactly the 
same error and I'm on OpenSuSE 11.4, not Ubuntu. I tried to run DK2.2 on 
KDE 4.7.1 and 4.7.2. From what I read I gather there is some 
compatibility issue related to KDE libs

Regards,
Larry

On 06/10/11 20:08, Ignatius Reilly wrote:
> Hi Philip,
>
> doesn't start after upgrading:
>
> eric at eric-desktop:~$ digikam
> QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is
> still in use, all queries will cease to work.
> digikam: symbol lookup error: digikam: undefined symbol:
> _ZN4KIPI21ImageCollectionSharedD2Ev
> eric at eric-desktop:~$
>
> Ubuntu 11.04
> SQLite DB
>
> Cheers
> Eric
>
>
> Philip Johnsson thus spake on 05/10/11 22:28:
>> In about 1-2 hours from I'm writing this digikam 2.2.0 will be able on
>> my PPA for Ubuntu 11.04 (natty). With this release I have adapted my
>> packages to the official digikam 2.1.1 package naming that is
>> introduced with Ubuntu 11.10 (oneiric). This mean that you have to
>> install the digikam and kipi-plugins package instead for the
>> transitional digikam2 and kipi-plugins2 that I used before on my PPA.
>>
>> With the renaming of the packages I had to resolve conflicts between
>> the old and the new packages but hopefully your package manager will
>> uninstall the old digikam2 and kipi-plugins2 packages for you when you
>> try to install the new digikam package. It would be great to get
>> feedback on how this update goes. It should work flawlessly.
>>
>> Other things that is different with my packages then the Ubuntu 11.10
>> packages is that on my PPA Digikam is built against and use OpenCV
>> 2.3.1 instead of OpenCV 2.1, Exiv2 0.22 instead of 0.22.1 and my build
>> also use libgphoto2 2.4.11.
>>
>> If you use Ubuntu 11.04 with standard KDE 4.6.2 then you only need my
>> "extra" PPA. If you use (K)ubuntu 11.04 with KDE 4.7.1 from the
>> Kubuntu teams PPA then you must use both my "extra" PPA and my
>> "kubuntu-backports" PPA.
>>
>> Happy digikaming!
>>
>> Philip
>> _______________________________________________
>> Digikam-users mailing list
>> Digikam-users at kde.org
>> https://mail.kde.org/mailman/listinfo/digikam-users
>>
> _______________________________________________
> Digikam-users mailing list
> Digikam-users at kde.org
> https://mail.kde.org/mailman/listinfo/digikam-users



More information about the Digikam-users mailing list