[Digikam-users] How to open RAW file in the Gimp?

Gilles Caulier caulier.gilles at gmail.com
Sat Jan 17 17:11:26 GMT 2009

2009/1/17 Simon Oosthoek <s.oosthoek at xs4all.nl>

> Jacek Poplawski wrote:
> > Dear Digikam users and developers,
> >
> > I am doing photos for a few years and I use Linux only. For a long
> > time I was just using gqview to browse photos and Gimp to edit them.
> > Now I am after session with RAW files, and gqview doesn't work anymore
> > for me, so I asked people on forums and groups about alternatives, I
> > tried some of them, but only digikam seams to work correctly.
> >
> > However, I am totally confused with its user interface. I am not a KDE
> > user (I use xfce4).
> >
> > I am able to open album with JPEG and RAW files, but for some reason
> > RAW files are created differently - digikam allows me only to open
> > them in showphoto. What I want to do is to open it in Gimp, so Gimp
> > will use ufraw plugin and I could edit my photo and store created JPEG
> > file somewhere.
> >
> > I tried to find some kind of options or preferences, I was looking
> > into to menus two or three times. Sure, there are options, but nothing
> > about applications to use with given file formats.
> >
> > Could you tell me what's the fastest way to open RAW file visible in
> > Digikam in any other application than showphoto? I use .orf files if
> > that matters. The only way I found for now is to do it manually from
> > bash.
> >
> What you need to do is to associate the raw file's mime type with
> gimp-remote. I'm not sure if this is a file-association for kde only,
> but the way to do it in KDE(3) is to go to the system configuration ->
> default applications -> file associations and then search for the raw
> mime types. If it doesn't exist, you may have to create one.

When association exists, "Open With..." option from pop-up menu must
contents gimp

> If you're running xfce4 you might try starting "kcontrol". I don't
> understand why digikam doesn't have a quick link to this configuration
> control, but perhaps this has never been put in a proper bug-report?

report already exist.

Gilles Caulier
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/digikam-users/attachments/20090117/b8cd2bf1/attachment.html>

More information about the Digikam-users mailing list