[Digikam-users] digkam albums don't update on the fly

Daniel Bauer linux at daniel-bauer.com
Thu Dec 31 15:11:56 GMT 2009

On Thursday 31 December 2009 15:21:34, DrMartinus wrote:
> Hi,
> I'm using OpenSuse 11.2 64 bit and used to use Digikam quite extensively,
> but now it's no fun anymore. Since the last update to OpenSuse 11.2 (now
> it's digikam version 0.10.0 release 6) I find that the albums don't update,
> until I close digikam and start it again.
> E.g. when I move images from one album to another, they stay in the album
> from which they originate and don't appear in the one where I moved them,
> until I close the app.
> The same when I delete images - they just stay there until I close the app.
> However, trying to perform an operation on those images tells that the file
> is not existing. And then the image isn't shown any more, but all the other
> meta info (like filename, creationdate etc.)
> Does anyone have an idea, what the reason could be? I didn't find anything
> yet in forums or other places that could help me.
> One idea I had was that there may be too many images in the folder, but
> before the "update" I had as many images and it worked fine. Current state
> is close to 9000 images in my working folder, from which I use to edit
> images, delete and put them in order (in different albums). The total
>  number of images in all albums is 50000.
> Thanks for all help!
> Martin
I can (almost) confirm this. Actually here the images *seem* to stay, but in 
fact it just takes a very long time until they appear in the new album where 
they are moved to, so it is definitively faster to close and restart the app.

Also, sometimes there are "ghost" images, i.e. after a large move I see 
wrongly selected images: I use to give one star to images I want to remove 
from an album and move it to "unused" for example. Then I select all images 
having one star, select them all (ctrl-a) and move them to the other folder 
with drag and drop. After a while the other pictures, that I have not tagged 
with one star, appear showing to have one star. Switching to another folder 
and back again resolves it...

I think there is something wrong with the database programming. I see many 
problems. Especially when moving pictures/folders around outside digikam, too. 
I rescently reorganized an album with some 120GB (using dolphin), moving and 
renaming folders etc. When restarting digikam it took more than 2 hours - but 
did not finish. In the end I deleted the digikam.db, to make digikam rebuild 
the db. After building approx 12 MB of db-file it just did nothing anymore, 
the process was "paused"...

So I moved to whole "album" to another place, deleted db, opened digikam with 
an emty album folder and imported all images back. This took about 6 hours. 
But at least it worked...

kind regards

Daniel Bauer photographer Basel Barcelona
professional photography: http://www.daniel-bauer.com

More information about the Digikam-users mailing list