[Digikam-users] SVN version crashes

Daniel Svärd daniel.svard at gmail.com
Tue Jun 24 18:19:15 CEST 2008


On Wed, Jun 25, 2008 at 12:33 AM, Gilles Caulier <caulier.gilles at gmail.com>
wrote:

> 2008/6/24 Daniel Svärd <daniel.svard at gmail.com>:
> >
> >
> > On Tue, Jun 24, 2008 at 10:35 PM, Gilles Caulier <
> caulier.gilles at gmail.com>
> > wrote:
> >>
> >> 2008/6/24 Daniel Svärd <daniel.svard at gmail.com>:
> >> >
> >> > On Tue, Jun 24, 2008 at 10:04 PM, Gilles Caulier
> >> > <caulier.gilles at gmail.com>
> >> > wrote:
> >> >>
> >> >> > Hi all,
> >> >> > the freshly checked out and compiled exiv2/digikam
> >> >>
> >> >> Hum, if you using Exiv2 from trunk, the tiff writing mode branch have
> >> >> been recently merged to trunk and now Exiv2 become very unstable.
> >> >>
> >> >> I'm currently working with Exiv2 author to stabilize code. please
> >> >> revert to last stable Exiv2 0.17.1. Do not use yet Exiv2 from trunk
> >> >> (future 0.18)
> >> >
> >> > The same thing happened for me with Exiv2 0.17.1 and the new Digikam
> >> > 0.9.4-rc1. I haven't compiled in enough debugging symbols to get a
> >> > proper
> >> > backtrace. I will try to do this as soon as I have some time.
> >> >
> >> > Reverting back to Exiv2 0.16 and Digikam 0.9.4-beta5 works. I have yet
> >> > to
> >> > try 0.16 with rc1.
> >>
> >> Warning : binary compatibility is not preserved between 0.16 and 0.17.
> >> if you don't recompile libkexiv2 used by digiKam and kipi-plugins you
> >> will see strange side effect... like crash (:=)))
> >
> > Oh, I just recompiled libkexiv2 when I updated to exiv2 0.17.1. Do I
> need to
> > recompile kipi-plugins too? I thought they just used libkexiv2 to access
> > exiv2. Anyways, if I don't recompile libkexiv2 it complains about not
> > finding the correct library version, so that's a given.
> >
> >>
> >> To be sure, please recompile libkexiv2 and exiv2 with full debug info,
> >> and send me gdb trace to hack
> >
> > I'll try to get a back trace for you now before I fall asleep. Is it ok
> to
> > attach it here, or should I link it from somewhere?
> >
>
> You can attach it here. attachement size to mailing list is limited to 40Kb
>

No need for that it seems. I just recompiled kipi-plugins as well, to enable
debugging symbols, and now it doesn't crash. It seems that this was the
problem. I just thought that since the same version of libkexiv2 was used
for kipi-plugins, only recompiling libkexiv2 would be enough. Clearly I was
wrong.

So in short (if anyone else suffers the same problem): upgrade exiv2 to
0.17.1, recompile libkexiv2 0.1.7, recompile kipi-plugins 0.1.5 and it
should work.

Anyway, now it's working, so I'm happy. Thank you Gilles for your quick
replies and I'm sorry for wasting your time. You're doing a great job with
Digikam.

Cheers,

Daniel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.kde.org/pipermail/digikam-users/attachments/20080625/b849ef2d/attachment-0001.html 


More information about the Digikam-users mailing list