[Digikam-users] Rename files on disk? - SOLVED

Jason Antman jason at jasonantman.com
Thu Jul 3 18:06:28 BST 2008

Problem solved. On a hunch, thinking back to the "import" at the
beginning of all this, I looked around.

A little background... I have *most* of my photos in ~/Pictures. I also
have some other scattered about, like the stuff from my serious
photography (giant ~200MB drum scans) that is on a separate partition,
/mnt/photos. I set digikam to have the album root at ~/Pictures, but
when I ran digikam next time, it started trying to index ~60GB of
photos. So I killed the process and edited ~/.kde/share/config/digikamrc
to have the new album root at ~/bin - the only directory that I *knew*
didn't have any images in it. Why have the program spend an hour
indexing photos when I only want to deal with 30 of them?

Well, on a hunch, I took a look at ~/bin, and sure enough found a new
directory - ebayPhotos2008-07-02. This was the same directory that I
imported from ~/Pictures when this problem started. All of the photos
are there, renamed, and rotated.

My observations/suggestions:
1) If the user imports a directory that's not in the album root, warn
the user that a copy will be created. Not only is this confusing, but I
sure am happy that I didn't import my 60GB directory and then leave for
a few hours.
2) I don't know if it's possible, but allow more than one "album root" -
i.e. allow in-place editing and indexing of files at random paths. This
is a big requirement for someone like me, who works with photos that, at
any given time, may be on 5+ partitions. I don't have space to copy all
of that to a working disk, nor do I want the files to go "missing" (or
have their changes be applied to a copy at another path).

Lastly, I haven't dug through the source, but I don't understand this
album on a remote mount issue. In Unix land, that type of stuff should
be transparent to applications. Everything's just a path, why does it
matter where it is? Shouldn't that be handled by the kernel, or FUSE, as
the case may be? My main non-photo data storage is mounted via
FUSE/SSHFS from a remote box, and I've never had a problem with any
other application, whether it be over the LAN or from work, or even via

Thanks for all of the help,

Mikolaj Machowski wrote:
> My guess: you didn't set permissions for files properly. In a way this
> is kind of digiKam bug: a) it should set permissions automatically b)
> should report if permissions don't allow for operations.
> m.
> _______________________________________________
> Digikam-users mailing list
> Digikam-users at kde.org
> https://mail.kde.org/mailman/listinfo/digikam-users

More information about the Digikam-users mailing list