[Digikam-users] Compiling 0.10.0-beta2 on kubuntu 8.0.4 with KDE4.1

Gilles Caulier caulier.gilles at gmail.com
Wed Aug 13 22:16:49 CEST 2008


sound like a problem with your env. setup.

For ubuntu, we have a bootstrap script here :

http://websvn.kde.org/trunk/extragear/graphics/digikam/project/bootstrap.ubuntu.8.04?revision=840728&view=markup

it can be adapted for kubuntu of course

Best

Gilles Caulier

2008/8/13 David Klasinc <bigwhale at lubica.net>:
> Greetings,
>
> anyone did this? Compiled beta2 on kubuntu 8.0.4 running KDE 4.1. KDE
> packages are from ppa.launchpad.net?
>
> I'm having problems with cmake unable to find libkipi, libexiv2,
> libkdcraw, and some other libs that are not required for build.
>
> I have all those libs together with -dev packages installed.
>
> # grep kipi_version /usr/lib/kde4/include/libkipi/version.h
> static const char kipi_version[] = "0.2.0-svn";
>
> According to README this is correct. Same goes for libkdcraw. It appears
> that cmake is looking for them in wrong directories.
>
> Other relevant variables:
>
> KDEDIRS=/usr/lib/kde4
> LD_LIBRARY_PATH=/usr/lib/kde4/lib
>
> I execute cmake from digikam-0.10.0-beta2/build directory
>
> Anyone has any thoughs on this issue? Where does cmake look for libkipi
> and other libs?
>
> Regards,
> David
> _______________________________________________
> Digikam-users mailing list
> Digikam-users at kde.org
> https://mail.kde.org/mailman/listinfo/digikam-users
>


More information about the Digikam-users mailing list