[Digikam-users] Compiling digikamimageplugins-0.9.0-beta

Paul Waldo pwaldo at waldoware.com
Wed Nov 1 17:00:37 CET 2006


Hi all,

I have just compiled digikam-0.9.0-beta3 and installed in /usr/local.  I'm now 
trying to compile digikamimageplugins-0.9.0-beta3, but I'm getting compile 
errors.  Here is what I have done:

export KDEDIRS=/usr/local
./configure --prefix=/usr/local
make

The first error I get is this:
adjustlevels.cpp:78: error: 'class Digikam::ImageIface' has no member 
named 'getOriginalImage'

I see the definition of this method 
in ../digikam-0.9.0-beta3/digikam/libs/widgets/imageplugins/imageselectionwidget.cpp.  "./configure --help" 
didn't give me any hints about telling configure where the digikam source 
lives.  Is there something else I need to do to tell the make where digikam 
lives?  Thanks in advance!

Paul


More information about the Digikam-users mailing list