[Digikam-users] Exiv2 library missing???

Fabien fabien.ubuntu at gmail.com
Tue Dec 5 14:26:15 GMT 2006

Daniel Bauer wrote:
 > [...]
> - deleted everything in /home/digi/digikamSVN and in /home/digi/digikam_svn
> - placed freshly downloaded scripts in /home/digi/digikam_svn
> - in console (as user daniel):
> 	su -l digi (+ password)
> 	cd digikam_svn
> 	./compile_exiv2.sh >compile_exiv2.out.txt 2>&1
> 	./compile_digikam.sh >compile_digikam.out.txt 2>&1
> Got the same errors.... 
> One thing I wonder: while running compile_digikam, in the results for the 
> Kipi_Plugins configure it says:
> -- Exiv2 library found............ YES
> but later in the same script, in the results for digiKam configure, it says:
> -- Exiv2 library found............ NO
> So it is as if it forgot where the Exiv2 library is during executing the 
> script?

Not really. The check made in configure script doesn't return true. I 
wonder why, I can't reproduce it here...

Can you try to run :
pkg-config --debug  --exists "exiv2 >= 0.12"

after using the exports in your shell ?

> I copied everything to my server, so you can see all the output. The above 
> mentioned lines are 1243 (Yes) and 5087 (no) in the compile-digikam-output. 
> I've also copied the used scripts on the server, but they should be exactly 
> what I've downloaded except of the changed path... But you can check, if I 
> messed up something, although I think I havn't.

It looks ok.

> b.t.w.:
> I wonder about the "/" at the end of the DIGIKAMDEST-path, because then 
> sometimes I see "/home/digi/digikamSVN//" with two "/". However, I've also 
> tried with leaving the final "/" away, didn't change anything. 

This is what I was wondering. I also tried, but it still ok for me. 
Double // is allowed, so it shouldn't be a problem. Anyway, I will fix 
it on the website...

Could you also put the graphics/config.log file in your website ?


More information about the Digikam-users mailing list