[Digikam-users] Problem downloading photos from Olympus D-300L

lhouk at lesliehouk.com lhouk at lesliehouk.com
Sun Sep 11 15:57:41 BST 2005

I have an Olympus D-300L digital camera, which uses the serial port to
communicate with the computer.  When I boot into Win2K and run the
software that came with the camera, a program called C-W95.exe, the camera
works perfectly, and I can download photos with no problems.

When I boot into Xandros (Desktop OS 3.0 Standard, build 2004-12-06 12:04,
all "latest updates" from Xandros Networks installed) and run digikam
(0.7.0-cvs, using KDE 3.3.0 and Kipi library version 0.1.0-cvs), it is
able to contact the camera on /dev/ttyS0 and list the files in /, showing
thumbnails of the photos correctly.  However, when I try to download the
photos, it always fails on the first photo, gives the error message
"Failed to download file P1010001.JPG", and aborts the download process. 
It doesn't matter whether I try "Download all" or "Download selected

I don't know if it is significant, but the Windows program generates files
named PIC00001.jpg, PIC00002.jpg, etc., instead of P1010001.JPG,
P1010002.JPG, etc.  I tried telling digikam to use it's own filenames with
the prefix PIC, but it still tried to download P1010001.JPG from the
camera, producing the same error.

For debugging purposes, I download the program camediaplay from
http://packages.debian.org/stable/graphics/camediaplay, which also failed.
 The output from two runs with the -d and -D debugging options are:

    $ camediaplay -D -v -a /dev/ttyS0
    ./../src/main.c:291: baudrate set to 19200
    ./../src/main.c:489: got 0x01 while waiting ACK(0x06)
    ./../src/main.c:911: ACK err in camedia_setspeed
    ./../src/main.c:291: baudrate set to 19200
    ./../src/main.c:563: got framing error
    ./../src/main.c:669: getpacket err in camedia_getint(01 10)
    ./../src/main.c:1057: getint err in camedia_getnpicts
    ./../src/main.c:570: illegal packet received: 0x00
    ./../src/main.c:669: getpacket err in camedia_getint(01 0a)
    ./../src/main.c:1063: getint err in camedia_getnpicts
    error getting npicts

    $ camediaplay -d -v -a /dev/ttyS0
    cpu>camera: 00
    camera>cpu: 00
    cpu>camera: 1b 53
    cpu>camera: 06 00
    cpu>camera: 00 11 02 00 00 00
    cpu>camera: 13 00
    camera>cpu: 15
    cpu>camera: 1b 43
    cpu>camera: 02 00
    cpu>camera: 01 10
    cpu>camera: 11 00
    camera>cpu: ff
    cpu>camera: 1b 43
    cpu>camera: 02 00
    cpu>camera: 01 0a
    cpu>camera: 0b 00
    camera>cpu: 00
    error getting npicts

Can anyone shed some light on what the problem might be, and what I can
try to get digikam to work with my camera?  Thanks in advance to all who


More information about the Digikam-users mailing list