[Digikam-users] Error during compile of .8 beta2

Andy Choens gunksta at gmail.com
Thu Oct 13 03:08:22 BST 2005

OK.  I'm running a copy of 64bit SUSE 10.

I would REALLY like to use the latest and greatest Digikam.  I've
gotten my dependencies compiled and installed.  A couple of bumps, but
nothing insurmountable.  But, now I've found an error I don't know how
to get around.

For the record I ran compile with the following options.
./configure --prefix=/opt/kde3 --with-qt-dir=/usr/lib/qt3
--with-qt-libraries=/usr/lib/qt3/lib64 --enable-libsuffix=64

Configure escapes cleanly and recommends I run make.  And, that's when
my trouble starts.  I've tried to do what I know how to do, and I
can't make this work.  If someone could hold my hand a little and
guide me through this, I'd be most appreciative.  I'd like to get
better at compiling my own programs.

Thanks ahead for all of your tips and suggestions.

Output from ld and make below:

relocation R_X86_64_PC32 against `QDir::operator!=(QDir const&) const'
can not be used when making a shared object; recompile with -fPIC
final link failed: Bad value
collect2: ld returned 1 exit status
make[4]: *** [libdigikam.la] Error 1
make[4]: Leaving directory
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/andy/errata/compile/digikam-0.8.0-beta2'
make: *** [all] Error 2
Eiger:/home/andy/errata/compile/digikam-0.8.0-beta2 # make -fPIC
make: PIC: No such file or directory
make: *** No rule to make target `PIC'.  Stop.

More information about the Digikam-users mailing list