Smugmug web service ported to O2 : Host authentication required

Thanh Trung Dinh dinhthanhtrung1996 at
Sun Jun 3 20:52:48 BST 2018

Hi Maik,

In fact, I added those lines and nickName is not always empty. In
I added a command line option for login with nickname. When you run
standalone test for smugmug with --login <nickname>, the nickname will be
propagated when the login page is opened, so that I can get the nickName
from user. In fact, It came from my misunderstanding. At that time, I had
succeeded with authentication, but when I tried to get current user info
from endpoint /api/v2!authuser (reference here
<>), I got the same
error of "authentication required" that I mentioned above. I had
misunderstood that there was problem with that endpoint, so in order to use
other APIs, I had to have nickname (at least), so I added that command line
option. However, later I found out that even with nickname, I still got the
same error when I tried to POST something via APIs. I finally figured out
that these endpoints (those I succeeded with GET) are public, so no need
for access token, and the problem still remains with endpoints needing
token (/api/v2!authuser is one of them). Therefore, it must be problem with
including auth token to the request.

I attache here a patch with my latest modifications so that you can test


On Sun, Jun 3, 2018 at 8:13 PM, Maik Qualmann <metzpinguin at> wrote:

> Hi Thanh,
> Look smugwindow.cpp: 232 the nickName is always empty. Therefore your
> login
> function will never be executed. I think login with nickname does not
> exist
> anymore, so the dialog for entering email and password can be removed as
> well.
> The LINK to Smugmug then works through the website, but the return Json
> code
> has changed.
> Maik
> Am Samstag, 2. Juni 2018, 23:49:42 CEST schrieb Thanh Trung Dinh:
> > Hi everyone,
> >
> > I'm porting digiKam web services with library O2, qt library for OAuth.
> > Working on Smugmug, I'm stuck with an error that I didn't understand.
> >
> > Smugmug uses OAuth 1.0 as authentication method, like Flickr, so I used
> same
> > methods to login, get user data, post photos, etc. In fact, I can login
> and
> > get access token using O2 methods. I also verified that the token I got
> is
> > the right one. However, whenever I tried to use that token to get/post
> > something, QNetworkReply returns with error 204
> > (AuthenticationRequiredError) and error message : "Host authentication
> > required". Besides, Smugmug has endpoints that don't require token to
> access
> > (e.g GET /api/v2/user/<nickname>). So when I tried normal GET method of
> > QNetworkManager it worked, but when I used specific method for GET in O2
> > (which prepares token and other necessary headers in the url request),
> that
> > error appeared,
> >
> > Did anyone see this message error when working with authentication
> before? I
> > really appreciate any help and guide, since I am really stuck here.
> >
> > Thanks,
> >
> > Thanh-Trung Dinh
> >
> >
> >
> > --
> > Sent from:
> f1695701.html

Mr. Thanh-Trung Dinh
Université de Technologie de Compiègne (UTC) - France
Tel: +33 7 53 68 20 29
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smugmug_O2.patch
Type: text/x-patch
Size: 34131 bytes
Desc: not available
URL: <>

More information about the Digikam-devel mailing list