[Digikam-devel] libkexiv2 on Kubuntu

Leonardo Giordani giordani.leonardo at gmail.com
Fri Jun 11 11:37:53 CEST 2010


Hi all digikam&&ubuntu users,

I'm trying to compile digikam SVN on Kubuntu Karmic 9.10: what I get is

-- checking for module 'libkdcraw>=1.1.0'
--   package 'libkdcraw>=1.1.0' not found
-- checking for module 'libkexiv2>=1.1.0'
--   package 'libkexiv2>=1.1.0' not found

However on my machine there are the two libraries installed (dpkg-query output)

ii libkdcraw7 4:4.3.5-0ubuntu1~karmic1
ii libkdcraw7-dev 4:4.3.5-0ubuntu1~karmic1

ii libkexiv2-7 4:4.3.5-0ubuntu1~karmic1
ii libkexiv2-7-dev 4:4.3.5-0ubuntu1~karmic1

I do not understand the version numbers of these packages: libkdcraw
is marked as 7 but digikam looks for version 1.1.0 or better, the same
for libkexiv2.

Questions for you:
1. How ca I determine the REAL version number of these libraries?
2. How can I install an updated version of them WITHOUT screwing up the system?

Thank you very much in advance

Leonardo


More information about the Digikam-devel mailing list