Review Request: sure new name for style is unique

C. Boemann cbr at boemann.dk
Sun May 13 00:30:47 BST 2012


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/104882/#review13755
-----------------------------------------------------------


Okay great. We are done with that now.

Now with all that settled here are some new things l would like to have done in this patch too


plugins/textshape/dialogs/ParagraphGeneral.cpp
<http://git.reviewboard.kde.org/r/104882/#comment10924>

    Here we need to make sure paragraphStylePage is on the page that shows then name and the name is preselected



plugins/textshape/dialogs/StyleManager.cpp
<http://git.reviewboard.kde.org/r/104882/#comment10927>

    do the:
    
    if (!unique)
      return
    
    dance at the beginning



plugins/textshape/dialogs/StyleManager.cpp
<http://git.reviewboard.kde.org/r/104882/#comment10925>

    widget.paragraphStylePage->setName(i18n("New style"));
    



plugins/textshape/dialogs/StyleManager.cpp
<http://git.reviewboard.kde.org/r/104882/#comment10926>

    widget.characterStylePage->setName(i18n("New style"));
    



plugins/textshape/dialogs/StyleManager.cpp
<http://git.reviewboard.kde.org/r/104882/#comment10928>

    drop this line



plugins/textshape/dialogs/StyleManager.cpp
<http://git.reviewboard.kde.org/r/104882/#comment10922>

    this can be simplified to just:
    
    return m_styleChanged;



plugins/textshape/dialogs/StyleManager.cpp
<http://git.reviewboard.kde.org/r/104882/#comment10929>

    drop this line



plugins/textshape/dialogs/StyleManager.cpp
<http://git.reviewboard.kde.org/r/104882/#comment10930>

    drop this line



plugins/textshape/dialogs/StylesModel.cpp
<http://git.reviewboard.kde.org/r/104882/#comment10923>

    please rename it to styleList()


- C. Boemann


On May 12, 2012, 11:09 p.m., mojtaba shahi wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/104882/
> -----------------------------------------------------------
> 
> (Updated May 12, 2012, 11:09 p.m.)
> 
> 
> Review request for Calligra.
> 
> 
> Description
> -------
> 
> when you add new style or when you change name of style, patch checks that the new name for
> 
> style is unique. patch doesnt let you to go another style or close dialog or apply and ok until the name
> 
> that you have choosen for your style be unique.
> 
> 
> Diffs
> -----
> 
>   plugins/textshape/dialogs/CharacterGeneral.h bb72b88 
>   plugins/textshape/dialogs/CharacterGeneral.cpp 4923087 
>   plugins/textshape/dialogs/ParagraphGeneral.h 5ef5c86 
>   plugins/textshape/dialogs/ParagraphGeneral.cpp 8ef5b7f 
>   plugins/textshape/dialogs/StyleManager.h 44dff97 
>   plugins/textshape/dialogs/StyleManager.cpp c318dd7 
>   plugins/textshape/dialogs/StyleManagerDialog.h 56e36b4 
>   plugins/textshape/dialogs/StyleManagerDialog.cpp d423ae0 
>   plugins/textshape/dialogs/StylesModel.h 53c0225 
>   plugins/textshape/dialogs/StylesModel.cpp 3b03f1b 
> 
> Diff: http://git.reviewboard.kde.org/r/104882/diff/
> 
> 
> Testing
> -------
> 
> it is ok and works right :)
> 
> 
> Thanks,
> 
> mojtaba shahi
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/calligra-devel/attachments/20120512/d2e7508c/attachment.htm>


More information about the calligra-devel mailing list