upgrading from 4.1 to 4.2 broke amarok

Gaetano Giunta giunta.gaetano at gmail.com
Sun Feb 22 15:35:40 UTC 2009

Diego a écrit :
> CCing the amarok mailing list, maybe someone there can help.
> Gaetano Giunta ha scritto:
>> Hello
>> I just tried upgrading from the latest 4.1 to 4.2.0, on win xp french.
>> The installer used to upgrade was 0.9.4.
> I don't think it changes anything but 0.9.5 is out.
In fact I updated it later and tried to run it again, but nothing 
changed in the end result.
>> The end result is:
>> - start menu icons are gone (all of the kde menu item)
> What happened to me is that the 4.1.3 menu disappeared but a brand new 
> 4.2.0 appeared... That's strange it didn't worked for you. :(
Are your menus for the current user only or for everybody (Default User)?
Apart form permission problems, I do not see why it should not work, either.

It would be nice to have a trace log of all actions carried out by the 
installer, though.

And it would be even better if the installer was able to recreate the 
missing icons when run at a later time...

>> - amarok throws an error at startup if I run its exe file: collection 
>> module missing
> That's strange too. Several users experienced the librivox issues in 
> 2.0.1 but this particular issue is the first time I hear of. Any hints 
> from the amarok ML?
Thanks for putting the amarok experts in the loop - I hope nobody gets 
offended because of cross-posting...


More information about the Amarok mailing list