[Ktechlab-devel] unit test.

Alan Grimes agrimes at speakeasy.net
Tue Jun 9 15:51:46 UTC 2009


>   Thanks for the documentation. In my opinion all these should be  
> documented in detail in the wiki. If there was a wiki :\

It's extensively documented in the literature. I have at least three
different textbooks which cover it. =P

>   Another important aspect of the simulator is how the components place  
> their equations in the matrix.

see "AddInitialDC"

>   Some ideas:

>   - it would be easier to read if the constructors were the first in the  
> .cpp file

perhaps...

>   - QuickVector has a memset() in its constructor -- personally I consider  
> that potentially dangerous

yeah, I'm trying to see if I can do away with that library completely.
However, there is no reason not to use it, the point is to apply the
fastest available method to initialize the vector. Memset is very close
to that, the only thing I know that might be better is a solution from
libOil.

Yes, it is performance sensitive code.

>   - mixing std::cout and kdDebug() output could cause stange output.  
> Because the math code is quite general, we could consider using only cout  
> for logging there. This could also eliminate any Qt or kde dependencies  
>  from the testcase(s).

I just comitted one better, the math library simply writes to an
"ostream" which can be passed any kind of ostream as a parameter. =)

>   - why does Matrix::fbSub have only one parameter, used both for input and  
> output? Isn't more elegant (and less error prone) if there were 2  
> arguments: "b" and "x" ?

yeah, probably. It's trying to optimize memory allocations.

-- 
New president: Here we go again...
Chemistry.com: A total rip-off.
Powers are not rights.





More information about the Ktechlab-devel mailing list