D27951: Allow users to change dropAction to MoveAction through kdeglobals

Nathaniel Graham noreply at phabricator.kde.org
Wed Mar 11 20:32:16 GMT 2020


ngraham added reviewers: VDG, davidedmundson.
ngraham accepted this revision.
ngraham added a subscriber: davidedmundson.
ngraham added a comment.


  Fantastic.
  
  I'm approving this since my concerns have been resolved and it works as you've indended it, but don't land it as it needs more discussion first. I know that @davidedmundson had concerns about this. Let's make sure everyone is included in the discussion.
  
  To be complete, we'll need companion patches to fix the cursor for various use cases (dolphin <-> dolphin, dolphin -> Folder View) and add a config UI for this in the Workspace Behavior KCM. Something like this:
  
    Drag and drop files: (o) Always ask what to do
                         ( ) Move files if location is on the same disk

INLINE COMMENTS

> dropjob.cpp:371
> +        const KConfigGroup g = KConfigGroup(KSharedConfig::openConfig(QStringLiteral("kdeglobals")), QStringLiteral("KDE"));
> +        if (g.readEntry("dndToMove", false) && (m_possibleActions & Qt::MoveAction)) {
> +            m_dropAction = Qt::MoveAction;

maybe we should call it something more descriptive, like "dndMoveByDefault"?

REPOSITORY
  R241 KIO

REVISION DETAIL
  https://phabricator.kde.org/D27951

To: trmdi, ngraham, dfaure, meven, #vdg, davidedmundson
Cc: davidedmundson, meven, kde-frameworks-devel, LeGast00n, cblack, GB_2, michaelh, ngraham, bruns
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20200311/503409f3/attachment.html>


More information about the Kde-frameworks-devel mailing list