[WebKit-devel] KWebWallet implementation committed...

Dawit A. adawit at kde.org
Tue Nov 24 08:25:37 CET 2009


I have comitted an implementation of KWebWallet that is mostly complete. It 
took longer than I had hoped for because of issues I encountered along the 
way, but I am finally done for the most part and the code is ready for review. 
Please note that the code has not been merged into kdelibs/kdewebkit until I 
completely finish this support and is ready for end user testing. Anyhow, here 
is a basic run down of things as they stand now:

# 1. KWebWallet will only support async calls to both save and restore form 
data. I have abondened sync calls because it causes more trouble than I like 
to get into here, but feel free to ask me if interested. To make a long story 
short I will not implement such support.

#2. KWebWallet was designed such the backend storage (KWallet) can be replaced 
by inheriting and implemeting 3 member functions as it stands now. I will add 
more documentation about this at some point before the API is sucked into 
kdelibs and prepared for 4.4 release. Anyhow, this requirement might make the 
code seem a little bit convolute ; if so please suggest ways you want to see 
it improved.

#3. Parsing form data was implemented by looking at how it is done in Arora 
and works with Qt 4.5. IOW, it does not require the new QWebElement classes 
available in Qt 4.6 ; so once I finish the frontend, hopefully before the end 
of the week, it can be tested with the current KDE 4.3.x release. Note that 
the code that parses forms is in its own function so it can easily be 
transitioned to use the Qt 4.6 provided classes in the future.

#4. As with all other KDE integration code, KWebWallet is enabled by default 
in KWebPage. This can be disabled by calling KWebPage::setWallet(0). In which 
case wallet integration is completely disabled...

#5. Until the GUI front end in the kwebkitpart can be provided, the code in 
KWebPage that calls saveFormData(...) is disabled for now.

Please look over the API and provide feedback with choice on public/protected 
member function names. Specifically I have changed resotreFormData to 
fillFormData since I last posted the API for review.


More information about the WebKit-devel mailing list