[umbrello] [Bug 430593] It shall be possible to nest folders in packages

Oliver Kellogg bugzilla_noreply at kde.org
Sat Dec 19 19:41:10 GMT 2020


https://bugs.kde.org/show_bug.cgi?id=430593

Oliver Kellogg <okellogg at users.sourceforge.net> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
      Latest Commit|                            |https://invent.kde.org/sdk/
                   |                            |umbrello/commit/afe54199882
                   |                            |d78ced2a04d520122a573b72151
                   |                            |e9
             Status|ASSIGNED                    |RESOLVED
         Resolution|---                         |FIXED

--- Comment #1 from Oliver Kellogg <okellogg at users.sourceforge.net> ---
Git commit afe54199882d78ced2a04d520122a573b72151e9 by Oliver Kellogg.
Committed on 19/12/2020 at 19:40.
Pushed by okellogg into branch 'master'.

Address 'It shall be possible to nest folders in packages' :

umbrello/model_utils.cpp
- In function typeIsAllowedInType case childType lvt_Logical_Folder,
  return true if parentType is lvt_Package.

umbrello/menus/listpopupmenu.{h,cpp}
- At functions
  - insertContainerItems(bool folderAndDiagrams, bool packages)
  - insertContainerItems(KMenu*, bool folderAndDiagrams, bool packages)
  split the single argument folderAndDiagrams into two separate
  arguments, `bool folders' and `bool diagrams'.

umbrello/menus/listpopupmenu.cpp
- In function insert(const MenuType, KMenu*) improve readability by
  - defining macro functions which factor the repeated code;
  - aligning the switch cases in quasi tabular form.

umbrello/menus/umllistviewpopupmenu.cpp
- In constructor with arguments QWidget*, UMLListViewItem*, in body of
  switch(type),
  - adjust code to changed signature of ListPopupMenu function
    insertContainerItems;
  - in case UMLListViewItem::lvt_Package call insertContainerItems with
    argument `folders' set to true.

umbrello/umllistview.cpp
- In function moveObject body of switch (srcType) handling of diagram
  types and lvt_Logical_Folder, admit case newParentType lvt_Package to
  execution of the move.

M  +147  -143  umbrello/menus/listpopupmenu.cpp
M  +2    -2    umbrello/menus/listpopupmenu.h
M  +5    -5    umbrello/menus/umllistviewpopupmenu.cpp
M  +3    -2    umbrello/model_utils.cpp
M  +2    -1    umbrello/umllistview.cpp

https://invent.kde.org/sdk/umbrello/commit/afe54199882d78ced2a04d520122a573b72151e9

-- 
You are receiving this mail because:
You are the assignee for the bug.


More information about the umbrello-devel mailing list