[umbrello-devel] [umbrello] [Bug 364120] Umbrello toolbar icons do not match diagram widgets and cursors running under "breeze" style

Oliver Kellogg via KDE Bugzilla bugzilla_noreply at kde.org
Mon Jul 11 16:46:45 UTC 2016


--- Comment #11 from Oliver Kellogg <okellogg at users.sourceforge.net> ---
(In reply to Ralf Habacker from comment #10)
> (In reply to Oliver Kellogg from comment #9)
> > FYI: Using Qt 4.8.6, I also got this unresolved symbol error on linking.
> > The following patch fixed it for me:
> I tried a KDE4/Qt 4.8 build of recent  umbrello master branch on jenkins
> without this patch and got no compile errors (see 
> https://build.kde.org/job/umbrello%20master%20latest-qt4/PLATFORM=Linux,
> compiler=gcc/31/console)
> Not sure how to reproduce this issue. Any hints welcome.

I am using gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04.3) i686-linux-gnu
on a Ubuntu 14.04.4 (trusty).
IMHO I am experiencing a GCC related problem.
Looking at /usr/include/qt4/QtCore/qglobal.h , we have:

#define Q_INIT_RESOURCE_EXTERN(name) \
    extern int QT_MANGLE_NAMESPACE(qInitResources_ ## name) ();

#define Q_INIT_RESOURCE(name) \
    do { extern int QT_MANGLE_NAMESPACE(qInitResources_ ## name) ();       \
        QT_MANGLE_NAMESPACE(qInitResources_ ## name) (); } while (0)

so basically they are the same except that Q_INIT_RESOURCE embeds the *extern*
declaration in a do-while block.

What GCC version are you using?

You are receiving this mail because:
You are the assignee for the bug.

More information about the umbrello-devel mailing list