[Uml-devel] [Bug 110843] Methods replaced with apparently random numbers after save

Yurgen Wolfgang raptorsforever at softhome.net
Fri Aug 19 23:23:18 UTC 2005

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

------- Additional Comments From raptorsforever softhome net  2005-08-19 23:26 -------
Whew! I downloaded the latest bleeding-edge Umbrello (1.4.89) from the branch you recommended. After compiling and installing, I proceeded to test it with my file. I decided to play it safe and pretty much gut the file by deleting all the message lines on the sequence diagrams and all the associations between classes on the class diagram. Then I tried recreating them, only to find none of the operations within my classes (that are within packages) in the New Operation->Operation Properties->General Properties->Type combo box. I tracked down that problem to the umldoc.cpp->getConcepts() operation where I changed the "pkg->appendInterfaces(conceptList);" line to "pkg->appendClassifiers(conceptList);" (as in Umbrello 1.4.2). My solution sounds weird, I know, and is probably not correct; but it put my classes' operations back into that list box where I could select them. Finally, I recreated all the assocations between the classes and after that, the message lines in the sequence diagrams. And guess what... no more weird operations appearing out of the blue. Well, at least for a while.

After saving and loading a few times and continuing to add more stuff to my file, a nice little operation named "108853" dropped by for a visit. He also appeared on my sequence diagram in the place of a legitimate operation. I tried redoing the class (on the class diagram) in which he appeared and the sequence diagram in which the class was used, but to no avail.  Friendly "108853" keeps coming back for tea and coffee. I just hope he doesn't start inviting his friends.

So what do I do now?

More information about the umbrello-devel mailing list