[Uml-devel] [Bug 110563] New: Undoing (Ctrl-Z) an Anchor causes entire diagram to be lost

Larry Weisberg lweisberg at finjan.com
Thu Aug 11 03:48:11 UTC 2005

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
           Summary: Undoing (Ctrl-Z) an Anchor causes entire diagram to be
           Product: umbrello
           Version: 1.4
          Platform: SuSE RPMs
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: general
        AssignedTo: umbrello-devel.kde.org
        ReportedBy: lweisberg finjan com

Version:           1.4 (using KDE KDE 3.3.0)
Installed from:    SuSE RPMs
OS:                Linux

I have a model with about 15-20 imported classes, a small class diagram (4 classes) and a small use case diagram (2 actors, 3 use cases).  In addition I am working on a sequence diagram showing  5 objects, with about 10-12 messages between them.  At one point I added 2 Notes.  The first one I anchored to a Synchronous Message.  Then I added another anchor for the 2nd Note to a different Synchronous Message.  I did not like how the 2nd one looked, so I did a <CTRL-Z>.  At that point the entire Sequence Diagram disappeared, and was replaced by 4-5 diagonal lines.  Also, the sequence diagram I was working on was now labelled as "class diagram."

I tried to quit w/o saving and re-enter umbrello but that did not help.  What is even more unusual - I had this happen yesterday, too.  So, I took a backed up version of the .xmi, (partial sequence diagram) and tried to re-do my work on another machine (also kde3.3, etc).  This time before I did the undo, I backed up the .xmi file.  Now, even when I run Umbrello with the backed up .xmi, I still have no sequence diagram.

More information about the umbrello-devel mailing list