[Uml-devel] [Bug 67327] New: Tree view from version 1.2 is not showing data from 1.1.1 files

Heather Krieg hsk at avaya.com
Wed Nov 5 14:05:26 UTC 2003

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
           Summary: Tree view from version 1.2 is not showing data from
                    1.1.1 files
           Product: umbrello
           Version: unspecified
          Platform: Compiled Sources
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: general
        AssignedTo: umbrello-devel at kde.org
        ReportedBy: hsk at avaya.com

Version:            (using KDE KDE 3.1.92)
Installed from:    Compiled From Sources

I've been trying out the new umbrello and attempted to load the XMI files from a 1.1.1 file.  When it loaded, it did not show anything in the tree but the initial class diagram.  The other diagrams were available from the Diagram->Show menu, but were not listed in the tree.  The classes and their properties were still intact in the diagrams.  I saved the file (under a different name, of course) and checked it out:  All of the <listitem> lines were removed except for that initial class diagram and the views (logical, use case, etc).

I reproduced the problem with a simple one-class file (no attributes or operations) built in Umbrello 1.1.1 and tried to open it with the new version.  The same thing happened.

I also tried copying the <listitem> section from the 1.1.1 file into the saved 1.2 file, but that didn't work either.

I have tried this with the 3.1.92 KDE as well as the kdesdk (and arts/kdelibs) CVS from 11-05-2003.

Another note: when I tried to create a new class (with the same name as one of the old class) umbrello crashed.  I expect that since the same-name-in-different-packages problem has been fixed, this is due to all of the classes in the old file being in the same "package".

More information about the umbrello-devel mailing list