[Uml-devel] [Bug 55810] Unable to compile on SPARC/SOLARIS 9

Lars Tunkrans lars.tunkrans at bredband.net
Tue Mar 11 14:07:16 UTC 2003

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

------- Additional Comments From lars.tunkrans at bredband.net  2003-03-11 23:03 -------
Subject: Re:  Unable to compile on SPARC/SOLARIS 9

This is what happends  I I delete "Flex" and  try to
use "lex"  instead.


pkgrm SMCflex

gmake distclean && ./configure


# gmake
cd . && /bin/bash ./config.status config.h
config.status: creating config.h
config.status: config.h is unchanged
gmake  all-recursive
gmake[1]: Entering directory `/opt/src/kde3apps/umbrello-1.1.1'
Making all in uml
gmake[2]: Entering directory `/opt/src/kde3apps/umbrello-1.1.1/uml'
Making all in classparser
gmake[3]: Entering directory `/opt/src/kde3apps/umbrello-1.1.1/uml/classparser'
lex -+ -otokenizer.cc tokenizer.l
lex: illegal option -- +
Usage: lex [-ewctvnVY] [-Q(y/n)] [file]
gmake[3]: *** [tokenizer.cc] Error 1
gmake[3]: Leaving directory `/opt/src/kde3apps/umbrello-1.1.1/uml/classparser'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/opt/src/kde3apps/umbrello-1.1.1/uml'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/opt/src/kde3apps/umbrello-1.1.1'
gmake: *** [all] Error 2

User Commands                                              lex(1)

      lex - generate programs for lexical tasks

      lex [-cntv] [-e | -w]  [ -V -Q
       [y | n] ] [file...]


Apperantly   "configure" finds "lex"  but the flags
are still in "flex"-style.

I Agree that the problem seems to bee some incompatability between
the modern GCC 3.2.2 and the somewhat dated flex from 1997/8

I even tried to rebuild "flex" from source .  Still the same "istream"


More information about the umbrello-devel mailing list