[Tellico-users] help with debugging CVS import hanging

Robby Stephenson robby at periapsis.org
Mon Mar 3 01:38:17 UTC 2014

Hi all,

There's a bug in Tellico  that results in a freeze/hang when importing a 
.csv file. It's bug 329677 on KDE [1] and #729503 in Debian [2]. 
Unfortunately, I can't reproduce it and I can't figure out the bug just 
from the backtrace in the KDE bug report.

So far, the only common denominators I see is that the bug (so far) is 
only on Debian and Ubuntu. Also, both original bug reporters were using 
LANG=fr_FR.utf8 system. SO maybe a character encoding issue? I've tried 
running Tellico with the same LANG and still no reproducibility.

Anyone else have this problem? Particularly on a non-Debian/Ubuntu 
system? Any programmers want to take a shot at looking at the CSV import 
code? It uses the libcsv library [3].

I may email the kde-devel list or ask on KDE irc, as well. I'd really 
like to get this fixed.


[1] https://bugs.kde.org/show_bug.cgi?id=3296772
[2] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=729503

More information about the tellico-users mailing list