[rkward-tracker] [ rkward-Bugs-3072835 ] NEEDINFO: Crash on Startup Win7

SourceForge.net noreply at sourceforge.net
Fri Oct 1 16:06:18 UTC 2010

Bugs item #3072835, was opened at 2010-09-21 17:59
Message generated for change (Comment added) made by 
You can respond by visiting: 

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: user interface
Group: CRASH
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: https://www.google.com/accounts ()
Assigned to: Nobody/Anonymous (nobody)
Summary: NEEDINFO: Crash on Startup Win7

Initial Comment:
http://bit.ly/agXHZ3 has details -- I don't see the point of duplicating them here. Information requested that isn't on the blog entry:

R version 2.11.1
Windows 7
KDE 4.4

R starts normally, both GUI and console versions on Windows7. Not sure about KDE, if I have time today, will test and report.


Comment By: https://www.google.com/accounts ()
Date: 2010-10-01 16:06

This is with the "Standard installation: complete installation bundle". I
also then downloaded R and KDE separately and received the same error.
KWrite starts normally. RKward still does not. I wonder if it's a 64/32-bit
issue? R is 64-bit, not sure about KDE. And I still get 0xc000007b, even in
safe mode. 

As for your PS, I couldn't run any diagnosis at work, so I blogged it and
filed a bug, now that you've responded, I can do further diagnosis. R on
its own runs without difficulty. So does KWrite (with the two admin access


Comment By: Thomas Friedrichsmeier (tfry)
Date: 2010-09-22 07:27

RKWard works just fine on Windows 7, here.

Note that on the first start of a KDE application, you will be prompted
for system/admin access in order to update mime database and configuration,
in two separate prompts. IIRC it is not strictly necessary to allow the
access, but naturally, you need to provide some answer to these prompts. So
as the very first thing, please try again, and watch out for any prompts
popping up, possibly hidden behind other windows.

If that does not work, please download, install, and try the binary
installation bundle (see http://p.sf.net/rkward/windows), in order to rule
out any problems with mismatching versions of R, KDE and RKWard.

If that still does not work, the error 0xc000007b appears to be not
entirely unknown on the internet, for a wide range of applications. Causes
appear to include certain malware, but also a restrictive setup of
ZoneAlarm. To rule out at least some of these causes, please try starting
windows in "Safe mode" and see if RKWard can be started, then.

If everything fails, it will indeed be interesting to know, whether you
can start any other KDE application (such as kwrite.exe).

Regarding RKWard on the Mac, have you actually tried, or does "it doesn't
run at all" mean, there is no end-user friendly installation method (which
there really isn't so far)?


P.S.: Thanks for taking the time to report this. But admittedly, "blog
first, ask questions later" does make my eyebrows go up a bit.


You can respond by visiting: 

More information about the rkward-tracker mailing list