rk.ANOVA / ezANOVA not working...

Aaron Batty abatty at sfc.keio.ac.jp
Thu Jan 14 10:43:39 UTC 2016

Well, guys, I tried all of Thomas' as well as Meik's suggestions, and
behavior is exactly the same.

Upgrading to R 2.3.2 gets rid of that part of the error, but the main thing
seems to be that it thinks that "ez" is not installed, when it is. No
matter what, when clicking "Submit" on the ANOVA setup window, I am told I
need to install "ez" (even though it is already installed), and when I go
to do that, I get a window with this error:

The package requested by the backend ("ez") was not found in the package
repositories. Maybe the package name was mis-spelled. Or maybe you need to
add additional repositories via the "Configure Repositories" button.

I have tried it with the Tokyo HTTPS one and UC Berkeley.

I have noticed that in the output as it installs, it always begins with

Warning: unable to access index for repository
  cannot open URL 'http://rkward.sf.net/R/bin/macosx/contrib/3.2/PACKAGES'
Warning: unable to access index for repository
  cannot open URL 'http://rkward.sf.net/R/bin/macosx/contrib/3.2/PACKAGES'
trying URL 'https://cran.ism.ac.jp/bin/macosx/contrib/3.2/ez_4.3.tgz'
downloaded 294 KB

This worked great in September, because I went through everything to make
sure it worked and updated my software manual for the class as appropriate.
It has to have been broken in one of the package updates, I think, because
on my 10.9 machines (my main machines), I haven't upgraded RKWard or R
(until just now, when I upgraded R from 3.1.2 to 3.2.3).

This is very bad timing... It's the last class of the semester before the

On Thu, Jan 14, 2016 at 7:06 PM, meik michalke <
meik.michalke at uni-duesseldorf.de> wrote:

> hi aaron,
> i have an additional suggestion:
> Am Donnerstag, 14. Januar 2016, 18:02:20 schrieb Aaron Batty:
> > In both 0.6.3 (R 3.1.2) on OSX 10.9 and 0.6.4 (R 3.2.2) on OSX 10.11
> [...]
> > Warning: package 'ez' was built under R version 3.2.3
> it looks like the installed ez package was built with a newer version of R
> than you are running. on OS X (and windows) this is more likely to happen
> than
> on linux, because linux builds R packages from source on the machine,
> whereas
> OS X and windows unpack precompiled binaries by default.
> running a package that was built for 3.2.2 in R 3.2.3 is usually no
> problem,
> but the other way round it can probably break things.
> you could try upgrading your R installation.
> viele grüße :: m.eik
> --
>   dipl. psych. meik michalke
>   institut f"ur experimentelle psychologie
>   abt. f"ur diagnostik und differentielle psychologie
>   heinrich-heine-universit"at d-40204 d"usseldorf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/rkward-devel/attachments/20160114/791f034e/attachment.html>

More information about the rkward-devel mailing list