rk.ANOVA / ezANOVA not working...

Thomas Friedrichsmeier thomas.friedrichsmeier at ruhr-uni-bochum.de
Thu Jan 14 09:41:45 UTC 2016

Hi Aaron,

On Thu, 14 Jan 2016 18:02:20 +0900
Aaron Batty <abatty at sfc.keio.ac.jp> wrote:
> Well, I just sat down to refresh my memory on doing ANOVAs in RKWard
> for class tomorrow, and find that I can't...
> In both 0.6.3 (R 3.1.2) on OSX 10.9 and 0.6.4 (R 3.2.2) on OSX 10.11,
> when running an ANOVA, I get a message saying that it needs the
> package "ez," but the package manager can't find it.
> If you just click "Okay" in the package manager, you get this in the
> output:
>   unable to load shared object
> '/Users/user/.rkward/library/minqa/libs/minqa.so':

this is the problem. At least one package needs re-installing. And
indeed RKWard is to blame for handling the case of updated R version,
badly, here.

1) Settings->Manage R packages and Plugins->Install / Update /
Remove->Update all packages. Likely but not guaranteed to fix the
problem, and may potentially mean re-installing quite a number of
2) Re-install package "minqa", only. Potentially the fastest solution,
but other packages could be broken, too. Rinse and repeat for these.
3) Safest: Move /Users/user/.rkward/library/ out of the way, and
install the packages you need from scratch.

> I've tried manually loading ez from the installed packages (it is
> listed but not loaded), but the same thing happens...
> Any ideas in the next 12 hours before I have to teach students to do
> this on the last day of class? (gulp!—it worked great last year; I
> guess I got overconfident!)

I suggest you try method 2, first, then method 3.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://mail.kde.org/pipermail/rkward-devel/attachments/20160114/9e31b593/attachment.sig>

More information about the rkward-devel mailing list