[rkward-devel] RKWard release nearing

Jaap Woldringh jjhwoldringh at ziggo.nl
Thu Feb 5 19:58:23 UTC 2015

Op 05-02-15 om 20:33 schreef Thomas Friedrichsmeier:
> On Thu, 05 Feb 2015 19:47:09 +0100
> Albert Astals Cid <aacid at kde.org> wrote:
>> El Dijous, 5 de febrer de 2015, a les 08:40:50, Thomas
>> Friedrichsmeier va escriure:
>>> Would it be enough, if I wrap all non-translatable terms in <i></i>
>>> (x, parameters, rk.header() are the ones missing)?
>>> Or do you need more than that / do you have a better idea?
>> I don't understand, what do you guys mean with this strings being
>> untranslatable?
> Hi,
> what I meant / thought was the problem, was that the string contains
> some terms that are function / variable names and should be kept as
> is in any translation. Not all of those were marked up, and at least
> for the term "parameters" (in this case the name of a function
> argument) that's clearly problematic.
> Anyway, the translator (Jaap) got back to me, and as far as I
> understand, the key issues he sees are something different:
> - these translation units are too large (at least one is much larger
>    than the example, I cited, too).
> - they contain too much markup (as a reminder, these are
>    HTML-formatted lists).
> Well, I can see those points. As you will have noted, these strings are
> rather atypical for us, and that's why I did not worry about this, so
> far. I can basically offer two possible solutions:
> 1. Split up the translation units "manually" (in the source, of
> course).
> 2. Automatically extract each bullet point in any list as a separate
> translation unit.
> 1) Would have the advantage(?) of allowing to keep short lists in one
> unit, while 2) would have the advantage of requiring less thought from
> the developer, and also stripping most markup.
> What do you think?
> Regards
> Thomas

I think the first point ("what I meant / thought was the problem...") is 
a valid one. Most times it is clear to me which terms should be 
translated, and which should not, but for translators who don't know any 
programming this might not be obvious, so any indication what should not 
be translated, is of course welcome. And I said: most times, not: always.

The second point is a most welcome answer to what I mentioned/complained 
about  in my previous mail, and I am very satisfied that it falls into 
fertile ground. Thank you for this.
I would say: any solution that keeps the messages short is welcome, so 
whether you choose possibility 1. or 2. is quite equal to me :).

Greetings from

Jaap Woldringh

More information about the rkward-devel mailing list