[Nepomuk] kde-4.4, virtuoso-6.1.0, and virtuosoconverter

Rex Dieter rdieter at math.unl.edu
Thu Feb 4 16:02:24 CET 2010

On 02/04/2010 07:43 AM, Sebastian Trueg wrote:
> Rex Dieter wrote:
>> FYI,
>> http://kde-apps.org/content/show.php/Nepomuk+Virtuoso+Converter
>> 1.  The requirements for kde-4.4/nepomuk have changed pretty late in the
>> game (after all 4.4rc's).
> No, they did not. I always said that Virtuoso 6 would be the dependency
> for KDE 4.4.

That's all well and good.

I had held off trying to use 6.0 myself, based on comments from you that 
it was buggy and didn't work, ie, waiting for 6.0.1 or 6.1, which has 
now landed.

Fact is that we're in a bad situation of now requiring something that's 
been untested and it's data is incompatible with what was tested.

>> 3.  the aforementioned data conversion tool (from 5.0.x) as-is seems...
>> less than optimal.
> "less than optimal" is way too detailed for me to give any feedback on.  ;)
> Anyway, the converter is hacky tool allowing early adopters of KDE 4.4
> who already tries Nepomuk with Virtuoso 5 (and thus, compile
> themselves!) to easily convert their data.

I get that.  I was hoping we could do better.  This is just a 
consequence of (1), and not having ample time to adapt to the new stuff.

-- Rex

More information about the release-team mailing list