[rekonq] Re: Review Request: Icon for add opensearch engine

Benjamin Poulain ikipou at gmail.com
Mon Dec 6 13:44:20 CET 2010


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/100064/#review456
-----------------------------------------------------------



"a/src/data/recherche_de_vid/303/251os_youtube.xml"
<http://git.reviewboard.kde.org/r/100064/#comment311>

    You should create a convention for content with languages. I would name the file youtube_search.fr.xml. This way one could filter the search options per language.



src/application.cpp
<http://git.reviewboard.kde.org/r/100064/#comment317>

    Fixing empty lines should be on a separate commit.



src/webtab.h
<http://git.reviewboard.kde.org/r/100064/#comment314>

    Why do you need this include here? There is no new call to QWidget in the header.



src/webtab.h
<http://git.reviewboard.kde.org/r/100064/#comment313>

    You can replace that by forward declaration if you pass the QPoint by ref-to-const.



src/webtab.h
<http://git.reviewboard.kde.org/r/100064/#comment312>

    The QPoint should be passed as reference to const:
    void showSearchEngine(const QPoint &pos). This is the convention for API consistency in Qt.



src/webtab.h
<http://git.reviewboard.kde.org/r/100064/#comment315>

    You don't use the arguments in the implementation, why put them? You can do connection signal-slots to a slot with less arguments.



src/webtab.cpp
<http://git.reviewboard.kde.org/r/100064/#comment316>

    You should use url.isRelative(). Building a Url object is relatively expensive, you'd better use the one you already have.


- Benjamin


On 2010-12-05 11:21:27, Lionel Chauvin wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/100064/
> -----------------------------------------------------------
> 
> (Updated 2010-12-05 11:21:27)
> 
> 
> Review request for rekonq.
> 
> 
> Summary
> -------
> 
> Icon at the right of the urlbar that allows to add an opensearch engine
> 
> 
> Diffs
> -----
> 
>   "a/src/data/recherche_de_vid/303/251os_youtube.xml" PRE-CREATION 
>   "a/src/data/wikip/303/251dia_(fr).xml" PRE-CREATION 
>   src/CMakeLists.txt f0310b4 
>   src/application.cpp 95aa9cf 
>   src/data/7digitalcom.xml PRE-CREATION 
>   src/data/CMakeLists.txt 5f49994 
>   src/data/beolingus.xml PRE-CREATION 
>   src/data/bliptv.xml PRE-CREATION 
>   src/data/bugzilla.xml PRE-CREATION 
>   src/data/citeseerx.xml PRE-CREATION 
>   src/data/cpan_search.xml PRE-CREATION 
>   src/data/de-en_beolingus.xml PRE-CREATION 
>   src/data/dictfr.xml PRE-CREATION 
>   src/data/duck_duck_go.xml PRE-CREATION 
>   src/data/ecosia.xml PRE-CREATION 
>   src/data/facebook.xml PRE-CREATION 
>   src/data/flickr.xml PRE-CREATION 
>   src/data/github.xml PRE-CREATION 
>   src/data/identica_people_search.xml PRE-CREATION 
>   src/data/kde_techbase.xml PRE-CREATION 
>   src/data/kde_techbase_(en).xml PRE-CREATION 
>   src/data/kde_userbase.xml PRE-CREATION 
>   src/data/kde_userbase_(en).xml PRE-CREATION 
>   src/data/leo_deu-eng.xml PRE-CREATION 
>   src/data/leo_deu-fra.xml PRE-CREATION 
>   src/data/portail_lexical_-_cnrtl.xml PRE-CREATION 
>   src/data/urban_dictionary.xml PRE-CREATION 
>   src/data/voila.xml PRE-CREATION 
>   src/data/wikia.xml PRE-CREATION 
>   src/data/wikia_(en).xml PRE-CREATION 
>   src/data/wikipedia.xml 4e15208 
>   src/data/wiktionary.xml PRE-CREATION 
>   src/data/wiktionary_(en).xml PRE-CREATION 
>   src/data/wolfram_alpha.xml PRE-CREATION 
>   src/data/wr_english-french.xml PRE-CREATION 
>   src/data/wr_english-italian.xml PRE-CREATION 
>   src/data/wr_english-spanish.xml PRE-CREATION 
>   src/data/wr_english.xml PRE-CREATION 
>   src/data/wr_french-english.xml PRE-CREATION 
>   src/data/wr_italian-english.xml PRE-CREATION 
>   src/data/wr_spanish-english.xml PRE-CREATION 
>   src/data/yippy.xml PRE-CREATION 
>   src/mainwindow.cpp c9863f0 
>   src/opensearch/opensearchengine.cpp 9d5e866 
>   src/opensearch/opensearchmanager.h 4f42b4a 
>   src/opensearch/opensearchmanager.cpp e5afc14 
>   src/opensearch/suggestionparser.cpp 4ed13e1 
>   src/settings/generalwidget.cpp 642813a 
>   src/settings/settingsdialog.cpp a3b4f97 
>   src/urlbar/listitem.h f5f1153 
>   src/urlbar/listitem.cpp f29a0e9 
>   src/urlbar/urlbar.h 67a693c 
>   src/urlbar/urlbar.cpp 1f4a036 
>   src/urlbar/urlresolver.cpp 57d6ca6 
>   src/urlbar/webshortcutwidget.h PRE-CREATION 
>   src/urlbar/webshortcutwidget.cpp PRE-CREATION 
>   src/webtab.h 12f528d 
>   src/webtab.cpp bac73fe 
> 
> Diff: http://git.reviewboard.kde.org/r/100064/diff
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Lionel
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.kde.org/pipermail/rekonq/attachments/20101206/21ee3d26/attachment-0001.htm 


More information about the rekonq mailing list