D26923: Fix systemtray configuration

Konrad Materka noreply at phabricator.kde.org
Sun Jan 26 09:59:43 GMT 2020


kmaterka added a comment.


  Thanks for noticing! The `currentValue` property was introduced <https://doc.qt.io/qt-5/qml-qtquick-controls2-combobox.html#currentValue-prop> with QtQuick.Controls 2.14 (Qt 5.14). Very convenient, unfortunately Plasma 5.18 must support Qt 5.12.
  
  BTW. QML import system is stupid (or I am :) ). Apparently, using `import QtQuick.Controls 2.5` will not allow you to use `currentValue`, but it will still conflict...

INLINE COMMENTS

> ConfigEntries.qml:196
>  
> -                            switch (currentValue) {
> +                            switch (model[currentIndex].value) {
>                              case "auto":

Instead of removing `currentValue` change it's name. This property is used in `KeySequenceItem`

> ConfigEntries.qml:267
>                          visible: isPlasmoid
>                          enabled: visibilityComboBox.currentValue !== "disabled"
>                          keySequence: model.applet ? model.applet.globalShortcut : ""

I won't work in Qt =< 5.13. Just rename `currentValue` to something not-conflicting.

REPOSITORY
  R120 Plasma Workspace

REVISION DETAIL
  https://phabricator.kde.org/D26923

To: carewolf, #plasma_workspaces, davidedmundson
Cc: kmaterka, plasma-devel, Orage, LeGast00n, The-Feren-OS-Dev, jraleigh, zachus, fbampaloukas, GB_2, ragreen, ZrenBot, ngraham, alexeymin, himcesjf, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, ahiemstra, mart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20200126/ac9c4037/attachment.html>


More information about the Plasma-devel mailing list