D26392: Add option to easily configure and start a hotspot

Aleix Pol Gonzalez noreply at phabricator.kde.org
Wed Jan 15 11:29:47 GMT 2020


apol added a comment.


  Patch looks good to me overall. +1

INLINE COMMENTS

> handler.cpp:615
> +
> +    QVariantMap options;
> +    options.insert(QLatin1String("persist"), QLatin1String("volatile"));

I'd prefer the initializer list syntax
`const QVariantMap options = { {QLatin1String("persist"), QLatin1String("volatile")} };`

> handler.cpp:623
> +    connect(watcher, &QDBusPendingCallWatcher::finished, this, &Handler::replyFinished);
> +    connect(watcher, &QDBusPendingCallWatcher::finished, this, static_cast<void (Handler::*)(QDBusPendingCallWatcher *)>(&Handler::hotspotCreated));
> +}

Use QOverload instead of static_cast, for readability.

REPOSITORY
  R116 Plasma Network Management Applet

REVISION DETAIL
  https://phabricator.kde.org/D26392

To: jgrulich, #plasma, ngraham, #vdg
Cc: meven, cblack, alexde, mthw, apol, plasma-devel, LeGast00n, The-Feren-OS-Dev, jraleigh, zachus, fbampaloukas, GB_2, ragreen, ZrenBot, ngraham, alexeymin, himcesjf, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, ahiemstra, mart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20200115/357be8af/attachment-0001.html>


More information about the Plasma-devel mailing list