D24798: Migrate QQC1 to QQC2
Nathaniel Graham
noreply at phabricator.kde.org
Mon Oct 21 05:01:14 BST 2019
ngraham requested changes to this revision.
ngraham added a comment.
This revision now requires changes to proceed.
++. The new table in the clock settings is much nicer anyway. :) See the following inline comments:
INLINE COMMENTS
> configTimeZones.qml:22
> import QtQuick 2.0
> -import QtQuick.Controls 1.2 as QtControls
> +import QtQuick.Controls 2.8
> import QtQuick.Layouts 1.0
`import QtQuick.Controls 2.5 as QQC2`
> configTimeZones.qml:53
>
> Rectangle {
> id: messageWidget
While you're doing some porting, this entire thing can be replaced with a `Kirigami.InlineMessage` which will drastically reduce the amount of code here, and you can also remove the `PlasmaComponents` import (`PlasmaCore` is still needed for units, unless you want to also port things to use `Kirigami.Units` instead)
> configTimeZones.qml:143
> + clip: true
> + spacing: 5
>
`units.largeSpacing` is preferable to hardcoded spacing values
> configTimeZones.qml:153
> + width: parent.width
> + text: !city || city.indexOf("UTC") === 0 ? comment : comment ? i18n("%1, %2 (%3)", city, region, comment) : i18n("%1, %2", city, region)
> + checked: model.checked
This is pretty hard to follow. I would recommend expanding it to a conventional if/else block for clarity.
> timezonesi18n.cpp:463
> {QStringLiteral("UTC+08:00"), i18nc("This is a generic time zone name, localize as needed", "UTC+08:00")},
> + {QStringLiteral("UTC+08:30"), i18nc("This is a generic time zone name, localize as needed", "UTC+08:30")},
> {QStringLiteral("UTC+09:00"), i18nc("This is a generic time zone name, localize as needed", "UTC+09:00")},
Seems unrelated; probably best done in another patch
> ConfigGeneral.qml:20
> import QtQuick 2.5
> -import QtQuick.Controls 1.4 as QQC1
> -import QtQuick.Controls 2.5 as QQC2
> +import QtQuick.Controls 2.5
> import QtQuick.Layouts 1.3
`import QtQuick.Controls 2.5 as QQC2`
> ConfigGeneral.qml:126
> + stepSize: 100
> + to: 1000000
> + textFromValue: function(value) {
Add `editable: true` and an appropriate `valueFromText` converter
> BreezeMenuStyle.qml:6
> +import QtQuick.Controls.Styles 1.4
> +import QtQuick.Controls 2.8
>
`import QtQuick.Controls 2.5 as QQC2`
> KeyboardButton.qml:6
>
> -import QtQuick.Controls 1.3 as QQC
> +import QtQuick.Controls 2.8
>
`import QtQuick.Controls 2.5 as QQC2`
> Main.qml:23
> import QtQuick.Layouts 1.1
> -import QtQuick.Controls 1.1
> +import QtQuick.Controls 2.8
> import QtGraphicalEffects 1.0
`import QtQuick.Controls 2.5 as QQC2`
> SessionButton.qml:25
>
> -import QtQuick.Controls 1.3 as QQC
> +import QtQuick.Controls 2.8
>
`import QtQuick.Controls 2.8 as QQC2`
> config.qml:25
> import org.kde.kquickcontrolsaddons 2.0
> -import QtQuick.Controls 1.0 as QtControls
> +import QtQuick.Controls 2.8
>
`import QtQuick.Controls 2.5 as QQC2`
> customwallpaper.qml:25
> import org.kde.kquickcontrolsaddons 2.0
> -import QtQuick.Controls 1.0 as QtControls
> +import QtQuick.Controls 2.8
>
`import QtQuick.Controls 2.5 as QQC2`
REPOSITORY
R120 Plasma Workspace
REVISION DETAIL
https://phabricator.kde.org/D24798
To: guoyunhe, #plasma, #plasma_workspaces, ngraham
Cc: ngraham, plasma-devel, LeGast00n, The-Feren-OS-Dev, jraleigh, fbampaloukas, GB_2, ragreen, ZrenBot, alexeymin, himcesjf, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, ahiemstra, mart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20191021/c438d280/attachment-0001.html>
More information about the Plasma-devel
mailing list