D23287: Create a plugin framework for processes
David Edmundson
noreply at phabricator.kde.org
Tue Aug 20 11:47:13 BST 2019
davidedmundson created this revision.
davidedmundson added a reviewer: Plasma.
Herald added a project: Plasma.
Herald added a subscriber: plasma-devel.
davidedmundson requested review of this revision.
REVISION SUMMARY
Currently everything for processes is hardcoded with a method for each
process property. This is core functionality like CPU usage and memory
usage but it's not very extensible.
Currently ProcessModel is full of extra hacks to add X11 data when
really it should be a dumb proxier of information.
We have a pending patch to show network stats, and we have a pending
patch to add powertop information, which all work in a different way
from just reading data in /proc
In order to keep it flexible a more generic format method is added which
doesn't require hardcoding knowledge of types.
This patch is part of a series, next steps are adding various plugins,
stripping proces model - and then using the ProcessAttribute class to
provide the metadata for the core process attributes so that
ProcessModel can become a very simple view with no code duplication.
REPOSITORY
R111 KSysguard Library
REVISION DETAIL
https://phabricator.kde.org/D23287
AFFECTED FILES
CMakeLists.txt
processcore/CMakeLists.txt
processcore/extended_process_list.cpp
processcore/extended_process_list.h
processcore/formatter.cpp
processcore/formatter.h
processcore/process_data_provider.cpp
processcore/process_data_provider.h
processcore/processes.cpp
processcore/processes.h
processcore/unit.cpp
processcore/unit.h
processui/ProcessModel.cpp
processui/ProcessModel_p.h
To: davidedmundson, #plasma
Cc: plasma-devel, LeGast00n, The-Feren-OS-Dev, jraleigh, fbampaloukas, GB_2, ragreen, Pitel, ZrenBot, himcesjf, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, mart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20190820/a861544c/attachment.html>
More information about the Plasma-devel
mailing list