D20265: Introduce libnotificationmanager

Nathaniel Graham noreply at phabricator.kde.org
Fri Apr 5 17:30:00 BST 2019


ngraham added inline comments.

INLINE COMMENTS

> org.freedesktop.Notifications.xml:57
> +      <arg name="inhibitors" type="a(ssa{sv})" direction="out"/>
> +    </method>-->
> +

Why is this commented out? Should it just be deleted instead? Or is it supposed to be used?

> job.cpp:175
> +        dirtyRoles.append(Notifications::ErrorTextRole);
> +    }*/
> +

What's this all about?

> notification.cpp:350
> +    // are there usecases for critical but can expire?
> +    // "critical updates available"?
> +    if (urgency == Notifications::CriticalUrgency) {

This would seem like an example of a notification that should not time out. I think what you've got here is a sane default.

> server_p.h:67
> +    void UnInhibit(uint cookie);
> +    //QList<Inhibition> ListInhibitors() const;
> +    bool inhibited() const; // property getter

What's this about?

> settings.h:213
> +    enum PopupPosition {
> +        NearWidget = 0, // TODO better name? CloseToWidget? AtWidget? AroundWidget?
> +        TopLeft,

I like `CloseToWidget`

REPOSITORY
  R120 Plasma Workspace

REVISION DETAIL
  https://phabricator.kde.org/D20265

To: broulik, #plasma
Cc: ngraham, plasma-devel, jraleigh, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, mart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20190405/b779e984/attachment.html>


More information about the Plasma-devel mailing list