D11352: [RFC] Auto ordered systray
Marco Martin
noreply at phabricator.kde.org
Thu Mar 15 19:59:06 UTC 2018
mart added a comment.
I like where this is going! (will still have to test it running tough)
one general thing i wonder, is if would be better to implementthe whole reorderItem() logic on the c++ side as is potentially heavy and complicated.. (and the actual reordering needs to be done in c++ already anyways)
INLINE COMMENTS
> AbstractItem.qml:81
> + function updateVisibility() {
> + Qt.callLater(updateItemVisibility, abstractItem)
> + }
what's the reson for using callLater?
> main.qml:65
> + ]
> + function getCategoryOrder(item) {
> + if (item.itemId == "org.kde.plasma.notifications") {
as convention we usually don't have getFoo as names (and this is not getting a property anyways)
i would like a more descriptive name like indexForCategory and have the category as parameter instead of the item
> main.qml:79
> + function reorderItem(item, container) {
> + if (container.children.length == 0) {
> + item.parent = container
i like the logic, but add some comments on what is doing
REPOSITORY
R120 Plasma Workspace
REVISION DETAIL
https://phabricator.kde.org/D11352
To: Pitel
Cc: wsdfhjxc, mart, plasma-devel, ZrenBot, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20180315/1a9261b8/attachment.html>
More information about the Plasma-devel
mailing list