D17703: Fix KIOClient non-interactive mode handling renamed prompts
David Edmundson
noreply at phabricator.kde.org
Thu Dec 20 00:24:21 GMT 2018
davidedmundson created this revision.
davidedmundson added a reviewer: Plasma.
Herald added a project: Plasma.
Herald added a subscriber: plasma-devel.
davidedmundson requested review of this revision.
REVISION SUMMARY
In the kdelibs to KF5 transition a factory class was adding for loading
rename prompts to make KIO gui-less.
In jobs "if (isInteractive)" was changed everywhere into "if
(uiDelegateExtension)".
The former was false if we called KJob::setUiDelegate(nullptr). The
latter is only false if the calling code explicitly calls the new
KIO::Job::setUiDelegateExtension(nullptr) as well.
This left kioclient5 in the very weird state of non-interactive mode
still having rename dialogs but not error messages.
Now non-interactive mode will simply error if it hits a conflict and
stop.
TEST PLAN
Copied a conflict
REPOSITORY
R126 KDE CLI Utilities
BRANCH
master
REVISION DETAIL
https://phabricator.kde.org/D17703
AFFECTED FILES
kioclient/kioclient.cpp
To: davidedmundson, #plasma
Cc: plasma-devel, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, mart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20181220/77e5db21/attachment-0001.html>
More information about the Plasma-devel
mailing list