D5961: PoC: Generic adoption of KUserFeedback for Discover
Volker Krause
noreply at phabricator.kde.org
Mon Jun 19 12:22:46 UTC 2017
vkrause added inline comments.
INLINE COMMENTS
> CMakeLists.txt:30
>
> +find_package(UserFeedback)
> +
Hm, looks like I forgot to rename this to KUserFeedback... Should probably done to be consistent with naming elsewhere. I'll look into it, and sorry for yet another SC change.
> DiscoverWindow.qml:114
> +
> + UserFeedback.Provider {
> + id: provider
You probably want to set submissionInterval to a fixed positive value for it to actually send data automatically. For best results, pick one that matches the time aggregation modes in UserFeedbackConsole (1, 7 or 30).
> DiscoverWindow.qml:119
> + feedbackServer: "http://localhost:8083/"
> + telemetryMode: UserFeedback.Provider.BasicUsageStatistics
> +
Note that this means you have basic telemetry enabled by default. If you want to let the user control this entirely, just drop the line. Same for surveyInterval above.
> DiscoverWindow.qml:133
> +
> + onShowEncouragementMessage: {
> + showPassiveNotification(i18n("You can help us improving this application by sharing statistics and participate in surveys."), 5000, i18n("Contribute..."), encouraged)
For this to trigger you will need to set some of the encouragement related properties on Provider, by default it's off.
REPOSITORY
R134 Discover Software Store
REVISION DETAIL
https://phabricator.kde.org/D5961
To: apol, #plasma, vkrause
Cc: mart, plasma-devel, ZrenBot, spstarr, progwolff, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, lukas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20170619/53a119d5/attachment.html>
More information about the Plasma-devel
mailing list