[Differential] [Changed Subscribers] D4551: Display speeds in bits per second instead of KiB/s
Sebastian Kügler
noreply at phabricator.kde.org
Fri Feb 10 14:42:58 UTC 2017
sebas added inline comments.
INLINE COMMENTS
> net.qml:43
> + function formatBitSpeed(value) {
> + if (value > 1048576) {
> + return i18nc("%1 is the data transfer speed in megabits per second", "%1 Mbps", (value / 1048576).toFixed(1));
Perhaps explain this "magic number" in a comment? (The more obvious this is, the easier it is to revisit in the future)
> net.qml:44
> + if (value > 1048576) {
> + return i18nc("%1 is the data transfer speed in megabits per second", "%1 Mbps", (value / 1048576).toFixed(1));
> + }
nitpick (to expand on David's explanation), the comment is now redundant (the string already gives the unit). The translators need context, often this means telling them where this string is displayed, so they can make a call what the actual translation would be, and test and verify the correctness. (Not super critical, but since we're talking i18nc semantics anyway, I thought it'd be useful to mention.)
REPOSITORY
R120 Plasma Workspace
REVISION DETAIL
https://phabricator.kde.org/D4551
EMAIL PREFERENCES
https://phabricator.kde.org/settings/panel/emailpreferences/
To: vishalrao, davidedmundson
Cc: sebas, Zren, davidedmundson, plasma-devel, lesliezhai, ali-mohamed, jensreuterberg, abetts, apol
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20170210/d6cf1204/attachment-0001.html>
More information about the Plasma-devel
mailing list