D9113: [WIP] ensure only one kpackage per applet
Aleix Pol Gonzalez
noreply at phabricator.kde.org
Sun Dec 3 09:55:16 UTC 2017
apol added a comment.
Otherwise LGTM.
INLINE COMMENTS
> packageurlinterceptor.cpp:99
> //qDebug() << "Intercepted URL:" << path << type;
> + if (path.toString().contains(QRegularExpression(QLatin1String("ui/.*\.js")))) {
> + QString rewritten = path.toString().replace(QRegularExpression(QLatin1String("ui/(.*)\.js")), QLatin1String("code/\\1.js"));
Move the QRegularExpression into a variable and reuse.
REPOSITORY
R242 Plasma Framework (Library)
REVISION DETAIL
https://phabricator.kde.org/D9113
To: mart, #plasma
Cc: apol, plasma-devel, #frameworks, ZrenBot, progwolff, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, mart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20171203/b2bc4be6/attachment-0001.html>
More information about the Plasma-devel
mailing list