[RFC] Plasma mobile components -> Plasma controls

Marco Martin notmart at gmail.com
Mon Feb 8 12:21:01 UTC 2016

Hi all,

It's almost time to make the plasma mobile components a framework/repository 
by itself, and with that I'm wondering of "plasma mobile components" it's even 
the proper name after all.

Following the Qt naming conventions i was going for "Plasma Controls" where 
"Plasma" is there purely for branding, but not as "dependency" (at least can 
be disabled at build time) and that is not reall "mobile" specific.
There are things that aren't really "mobile" , like colors and listviews..
one could use pieces of them in desktop apps and plasmoids as well, as long as 
doesn't use the really mobile specific parts.

so a name should be:
* Exprime that it's something "extra", it's not the "buttons and textboxes" of 
* Exprime that is ours (would go for Plasma instead of KDE for the usual KDE 
is people)
* I wouldn't stress too much on it being "mobile"

Opinions? comments?

Marco Martin

More information about the Plasma-devel mailing list