QWeakPointer error in DrKonqi

René J. V. Bertin rjvbertin at gmail.com
Fri Feb 5 08:59:50 UTC 2016

Aleix Pol wrote:

> Maybe you can provide the fixes in the shape of a review request? I'm
> sure that if somebody found this they would have fixed it before.
> I really have no idea why these issues didn't pop up on my set up but
> did on yours anyway.

That's weird indeed. I just tried to build on Linux without the fixes but with as 
much as possible the same configure/build/packaging scripts, and I get the same 
errors about QWeakPointer and QString::fromAscii().

This is clearly not related to using (Apple's) clang vs gcc (5.3 on my Linux 

Annoyingly there must be something wrong with my QWeakPointer "fix"; DrK crashes 
when I click on the "save" button to record a backtrace. According to the new 
DrK instance that then opens, the crash occurs in a QFileDialog method which 
somehow gets called with this==NULL.

Something else must be wrong with my Linux build, as DrK claims it doesn't know 
the reporting address where it has no such issues on OS X.

I'll look at this some more, but is a RR really the best way to get a discussion 
on this rolling if I'm not even 100% sure that my fixes are correct?


More information about the Plasma-devel mailing list