[Differential] [Changed Subscribers] D2502: New design for logout screen
broulik (Kai Uwe Broulik)
noreply at phabricator.kde.org
Fri Aug 19 12:58:28 UTC 2016
broulik added inline comments.
INLINE COMMENTS
> Logout.qml:45
> + function sleepRequested() {
> + suspendRequested(2);
> + }
Can we have an enum for that?
> Logout.qml:67
> + onTriggered: root.cancelRequested()
> + shortcut: "Escape"
> + }
There's no "Return"/"Enter" to accept, is there?
Also, I think the arrow keys should switch between the modes to fully allow using the dialog with keyboard only.
> Logout.qml:104
> + ColumnLayout {
> + id: prompts
> + anchors {
Unused id
> Logout.qml:122
> + action: root.sleepRequested
> + opacity: 0.6
> + }
Suspend might not be available on the machine, should not be shown then.
Also, what about hibernate?
> Logout.qml:128
> + action: root.rebootRequested
> + opacity: sdtype == ShutdownType.ShutdownTypeReboot ? 1 : 0.6
> + }
Given you already set currentAction based on the sdtype, could be simplified to
opacity: root.currentAction === action ? 1 : 0.6
This would also ease the keyboard nav stuff.
REPOSITORY
rPLASMAWORKSPACE Plasma Workspace
REVISION DETAIL
https://phabricator.kde.org/D2502
EMAIL PREFERENCES
https://phabricator.kde.org/settings/panel/emailpreferences/
To: mart, #plasma
Cc: broulik, plasma-devel, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20160819/10a41fe2/attachment.html>
More information about the Plasma-devel
mailing list