Review Request 128612: Add translation domain to wallpaper QML object

Friedrich W. H. Kossebau kossebau at kde.org
Fri Aug 5 14:23:40 UTC 2016


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/128612/#review98145
-----------------------------------------------------------



Thanks for the quick reaction :)

IMHO it makes sense, as it allows the code in the wallpaper qml itself to be more clean and easier to read.

Compare
```
        text: wallpaper.configuration.DisplayText ||
              i18nd("plasma_wallpaper_org.kde.plasma.textwallpaper", "<Please configure a text to display>")
```
to
```
        text: wallpaper.configuration.DisplayText || i18n("<Please configure a text to display>")
```

- Friedrich W. H. Kossebau


On Aug. 5, 2016, 1:56 p.m., David Edmundson wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/128612/
> -----------------------------------------------------------
> 
> (Updated Aug. 5, 2016, 1:56 p.m.)
> 
> 
> Review request for KDE Frameworks and Plasma.
> 
> 
> Repository: plasma-framework
> 
> 
> Description
> -------
> 
> Add translation domain to wallpaper context.
> 
> 
> Diffs
> -----
> 
>   src/scriptengines/qml/plasmoid/wallpaperinterface.cpp 507c82f03b76a948e1c8e07e546756a172359a40 
> 
> Diff: https://git.reviewboard.kde.org/r/128612/diff/
> 
> 
> Testing
> -------
> 
> Tested with qDebug.
> 
> not convinced if it makes sense unless the config view is also fixable.
> 
> 
> Thanks,
> 
> David Edmundson
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20160805/58c3bb38/attachment.html>


More information about the Plasma-devel mailing list