Review Request 125698: Fix Button minimumWidth property
David Edmundson
david at davidedmundson.co.uk
Mon Oct 19 10:31:02 UTC 2015
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/125698/
-----------------------------------------------------------
(Updated Oct. 19, 2015, 10:31 a.m.)
Status
------
This change has been marked as submitted.
Review request for Plasma.
Changes
-------
Submitted with commit 1a4c1d7eebcf1e901b3109b26bae70c56a80f0d2 by David Edmundson to branch master.
Bugs: 353584
http://bugs.kde.org/show_bug.cgi?id=353584
Repository: plasma-framework
Description
-------
Remove duplicate code expanding size hint of panel to fit text (line 114)
QtQuickControls already does this inside Button code. This hint is simply a
"what's the default size for a panel to be".
-----
Fix Button minimumWidth property
Plasma's Button has an extra property "minimumWidth" which is an extra
hint not in QQC to say "Smallest width this button can be to show all the contents.".
(it's a bit confusing, as we can perfectly handle a button below it's
"minmimum" size)
This should be based on the size the contents want to be (the
implicitWidth), not how small the contents can go. Given our button text elides we currently return the size of icons + spacing, but not text, which is rather useless.
It got broken at some point recently.
BUG: 353584 - make screenlocker keyboard selector big enough to see the letters
Diffs
-----
src/declarativeimports/plasmastyle/ButtonStyle.qml a242186ab7b45bc09ff83eee1a51358132d897f1
tests/components/button.qml fdfc42d589c40fe11c193920befd055ce8383762
Diff: https://git.reviewboard.kde.org/r/125698/diff/
Testing
-------
Thanks,
David Edmundson
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20151019/39ee2a36/attachment.html>
More information about the Plasma-devel
mailing list