Review Request 125698: Fix Button minimumWidth property

David Edmundson david at davidedmundson.co.uk
Sun Oct 18 23:29:40 UTC 2015


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/125698/
-----------------------------------------------------------

(Updated Oct. 19, 2015, 1:29 a.m.)


Review request for Plasma.


Bugs: 353584
    http://bugs.kde.org/show_bug.cgi?id=353584


Repository: plasma-framework


Description
-------

Remove duplicate code expanding size hint of panel to fit text (line 114)

QtQuickControls already does this inside Button code. This hint is simply a 
"what's the default size for a panel to be".

-----

Fix Button minimumWidth property

Plasma's Button has an extra property "minimumWidth" which is an extra
hint not in QQC to say "Smallest width this button can be to show all the contents.".

(it's a bit confusing, as we can perfectly handle a button below it's
"minmimum" size)

This should be based on the size the contents want to be (the
implicitWidth), not how small the contents can go. Given our button text elides we currently return the size of icons + spacing, but not text, which is rather useless.

It got broken at some point recently.


BUG: 353584 - make screenlocker keyboard selector big enough to see the letters


Diffs
-----

  src/declarativeimports/plasmastyle/ButtonStyle.qml a242186ab7b45bc09ff83eee1a51358132d897f1 
  tests/components/button.qml fdfc42d589c40fe11c193920befd055ce8383762 

Diff: https://git.reviewboard.kde.org/r/125698/diff/


Testing
-------


Thanks,

David Edmundson

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/plasma-devel/attachments/20151018/ba2c7d29/attachment.html>


More information about the Plasma-devel mailing list