Notes from "Async and representation"

Mark Gaiser markg85 at gmail.com
Wed Jan 15 19:36:24 UTC 2014


On Wed, Jan 15, 2014 at 6:19 PM, Marco Martin <notmart at gmail.com> wrote:
> On Wednesday 15 January 2014 16:43:43 Mark Gaiser wrote:
>
>> As for the Applet name. Why that name? I'm making a plasmoid, right?
>> So name it as such:
>> Plasmoid {
>>   ...
>> }
>>
>> That is also easier to explain to a user:
>> "To create a plasmoid you have to create a root QML item named
>> Plasmoid { ... } which must contain the following properties ... bla
>> bla, you get the point."
>
> i would call it Plasmoid if i can merge it with the plasmoid object, that is
> now an object registered in the root context. i'm not sure it's possible,
> would like to tough.

>From my "relative outsider view" Plasmoid {} seems far more obvious
then Applet {} so if the plasma folks agree on that then i would go
for that.

As for the current Plasmoid in the root context.. That can go and be
merged in this Plasmoid {}. You always need to have that object anyway
thus the result will be the same. Only now it will be created
"because" you defined it and not just injected in the root context :)

Sounds like a win/win to me.

The only downside is required refactoring :p

>
>>
>> Then yet another note.
>> You say users must provide a:
>> minimumWidth: ...
>> minimumHeight: ...
>>
>> which is being defined in the root item (whatever it ends up being).
>> But why there? I mean, the compactRepresentation and
>> fullRepresentation are likely to have their own different minimal
>> width/height. It "could" be the same, yes. But it could also be wildly
>
> good point, compactRepresentation and fullRepresentation should export those
> as attached properties, and the root object should not.

Just so that it's clear. So you just basically decided that the bare
minimum for a plasmoid (in plasma 2) is likely going to look like
this:

Plasmoid {
     compactRepresentation: Component {
         minimumWidth: ...
         minimumHeight: ...
     }
     fullRepresentation: Component {
         minimumWidth: ...
         minimumHeight: ...
     }
}

right?

Now i'm starting to like it since - to me - it now makes sense.
For those two representations. I would say that one must exist.
Neither is mandatory on it's own, but one must be there at all time.

>
>> the smallest minimal (likely compactRepresentation) but then it's just
>> a bogus value for the other one (likely fullRepresentation).
>>
>>
>> I hope you find my feedback valuable and not nitpicking :)
>
> all feedback is ;)
>
> --
> Marco Martin
> _______________________________________________
> Plasma-devel mailing list
> Plasma-devel at kde.org
> https://mail.kde.org/mailman/listinfo/plasma-devel


More information about the Plasma-devel mailing list