Qt Kinetic + Plasma Call For Ideas / Project Plan

Akmanalp, Mehmet A makmanalp at wpi.edu
Thu May 28 23:14:18 CEST 2009


On Thu, May 28, 2009 at 9:38 PM, Aaron J. Seigo <aseigo at kde.org> wrote:
> Animation *a = Animator::fadeIn(item);
> Animation *b = Animator::add(a, Animator::bounce(item, timesToBounce));
> a = Animator::while(b, Animator::blur(item, amount));
> Animator::add(a, Animator::fadeOut(item));
> // auto starts when event loop is hit again, unless a->stop() is called
>
> Animation *a = Animator::fadeIn(item);
> Animator::bounce(item, timeToBounce, a, Animator::Add);
> Animator::blur(item, amount, a, Animator::While);
> Animator::fadeOut(item, a, Animator::Add);
Honestly, I think the add / while syntax is a little unintuitive,
which is a minus since we're trying to make things as simple as
possible. Also, what if  want the blur to happen  during the fadein
and the bounce? I don't see how you'd do this with add-while without
grouping the fadein and blur.

> * means two phase learning curve (Animator's shortcut, then Kinetic) if you
> need to "graduate" from Add/While in Plasa::Animator to Kinetic's groups
Following the previous statement, I'd say we just ditch add / while.
This way, it'd be more consistent with Kinetic *and* it'd be a little
more intuitive (imho).

Even if we don't create a whole new language as Ivan proposes, we
could imitate it in the name of ease of use:

Animator a;
a.animate(item,
  a.series(
    a.fadeIn(),
    a.parallel(
      a.blur(amount, time),
      a.series(
	a.bounce(timesToBounce),
	a.flip()
      )
    ),
  a.fadeOut()
  )
);

Although the a. in the beginning of all of those is a bit annoying. Thoughts?


More information about the Plasma-devel mailing list