Extender api review.
Richard Moore
richmoore44 at gmail.com
Thu Jul 24 00:59:01 CEST 2008
Just the minor stuff:
Applet
=====
bool supportDetachables() const;
should be:
bool supportsDetachables() const;
void setForcePanelCollapse(bool collapse);
This name is pretty much meaningless, it should be renamed, I'm not
sure what is better though.
bool forcePanelCollapse() const;
For boolean flags we have a convention that the getter will be named
something hasXX or isXX, this breaks that convention.
QString noDetachablesLabel() const;
Can someone figure out what this does from the name? I'd say no.
void setSupportDetachables(bool supportDetachables);
should be
void setSupportsDetachables(bool supportDetachables);
DetachableWidget
=============
name() -> const
bool detachable();
should be
bool isDetachable() const;
bool collapsed() const;
should be
bool isCollapsed() const;
Corona
=====
void addExtender(Applet *extender);
no corresponding remove?
I suspect there are several missing slots, in the above too. In
addition defining some Q_PROPERTIES would be a good idea. This is just
a quick run through without paying attention to the semantics of the
operations themselves.
Cheers
Rich.
More information about the Plasma-devel
mailing list